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TO USE THIS DOCUMENT 

The document is arranged in sections, which can be 

overviewed in the Table of Contents.  It is subsequently 

broken down as an outline.   

Descriptions and purposes are listed in black 

Instructions for execution are highlighted in purple 

Questions are highlighted in burnt orange 

 

 

YOU WILL NEED 

• QGIS 3.0 (2.8 and 2.1.8 are acceptable, but some 

menu options and names differ) 

o Workflow in QGIS 3.2 has not been tested.  As 

with 2.8 and 2.1.8, some menu options may 

differ 

• Notepad ++, KomodoEdit, or your preferred IDE 

• Notepad 
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GETTINGS STARTED 

1. Adding data 

a. Go to <tinyurl.com/uwayatut> 

i. Navigate to QGIS Tutorial page and download the firs tutorial file archive 

1. Extract the file to your U Drive (flash drive, or preferred location) 

b. In QGIS, click Layer → Add Layer → Add Vector Layer 

i. In the Source box, clikc the […] button 

ii. Add “K12_Schoos.shp”, and press OK 

iii. Click the Add button 

iv. Repeat steps bi-iii with “Schoold_Districts__Washington_State.shp” and 

“Montessori_Schools__Washington_State.shp” 

v. When all three layers have been added, click Close 

c. If your school district layer opened above the two point layers, you may not be able to 

see any points on your map 

i. Look to the bottom left, and you will see your layer controls 

ii. Drag the School District layer to the bottom, and the Montessori School layer to 

the top 

d. You can change the colors and shapes of your layers 

i. Double-click the colorful circle to the left of the Montessori School Layer, and 

change it to red 

1. Play around with the color slider until you find a shade that you like 

ii. Double-click the colorful cirle to the left of the K-12 School Layer, and change it 

to blue 

iii. Double-click the colorful box next to the School District layer and change it to a 

shade of beige 

iv. If you’ve clicked on a layer and it takes you to another Properties Menu item, 

click Symbology 

e. Save your progress so far 

i. At the top left, click Project → Save As… 

ii. Navigate to your preferred working folder, and call the file “WASchools” 

f. You can also turn rows on and off 

i. For now, uncheck the box next to the Montessori school layer 

 

2. Navigating the Analytical Interface 

a. Right-click the K12_Schools layer, and click Open Attributes Table 

i. The attributes table is where all of your data is stored 

ii. Each point has a data entry for each attribute 

iii. The column heads are clickable 

1. Click the column head for “District”: What does it do? 

___________________________________________ 

iv. Pan across the top row of buttons 
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1. The Editor pencil allows you to make permanent modifications to the 

table 

a. You must toggle this setting on and off to make textual changes 

to the table 

b. You can select features using an expression or formula 

c. You can also activate the Filter function 

d. Name one other function available in this screen: 

______________________________ 

v. On the bottom-left, click blue funnel 

1. This pulls up several other “show” features, such as showing only 

selected features 

2. Using these features does not modify your dataset 

vi. Close the attributes table 

vii. In the top row of buttons, click the magnifying glass with a “+” in it 

1. Click near a clustering of points and drag a box around them to zoom in 

(I start with Spokane) 

viii. Double-click the School Districts layer 

1. This is the Properties window 

a. You can also reach it by right-clicking the layer and selecting 

Properties 

b. Here, you will be able to access many options, such as 

symbology for making choropleth maps, selecting labels, 

building diagrams, and conducting joins 

2. Click the Labels button 

a. In the drop menu, select Show labels for this layer 

b. Label With “NAME” 

c. Feel free to choose any font from the drop menu, and click OK 

d. Which school districts are in the viewing extent of your 

selection? __________________________________________ 

3. Click the white hand tool to pan around the map 

a. Click and drag 3 times in any direction. What do you see now? 

___________________________________________________ 

4. Roll the mouse wheel towards your palm to zoom out and pan to a new 

cluster 

5. Zoom in on that cluster (I went to Yakima) 

ix. In the top row of buttons, look for the white “I” in a blue circle – this is the 

“identify” tool 

1. Select the tool, and click any of the school districts that are in view 

a. What is the Educational Service District (ESD) of the selection? 

_______ 

b. What is the region number? _____ 

x. To the right of the Identify tool, click the white arrow with the yellow box for 

Select Features 
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1. Click any of the points representing schools 

a. Note, QGIS does not carry out single selects on polygons 

2. Right-click the K-12 schools layer, and Open Attribute Table 

3. On the bottom-left, open the funnel drop menu that currently says 

Show All Features 

4. Change it to Show Selected Features 

5. Click back to the main window 

a. Click and drag the selector tool just like you did the magnifying 

glass, and try to capture as many points as you can 

b. Click back to your attribute table window, and look at the top 

bar 

c. How many points were you able to select? ______________ 

6. Two spaces to the right of the Select Features tool, click the yellow box 

with the red “X” to clear selected features 

7. Close the attributes window 

 

SELECTING SPATIALLY and SPATIAL JOINS 

3. Selecting by Location – and Saving 

a. Open the attributes table for School Districts 

b. Click the column header for “Name” one time, and select the row indicator “11” for 

“Bellingham” 

c. At the top of the attributes table window, click the yellow box with four blue arrows 

facing in the cardinal directions – Pan map to the selected rows 

i. Alternatively you can use CTRL+P 

d. Along the top row of drop menus, select Processing → Toolbox 

e. In the newly opened side pane, select Vector Selection → Select by Location – make 

sure that the School Districts layer is selected in your layers list 

i. Select Features:  the K12 schools layer 

ii. Fill the checkbox for Are Within 

iii. By comparing features from: the School districts layer 

iv. Fill the checkbox for Selected features only 

v. Make sure that creating new selection is active in the drop menu 

vi. Click the Run button 

vii. Look to the bottom-left: how many features were selected in the K12 schools 

layer? _____________ 

f. Use the selector arrow to click on the neighboring Mount Baker school district – Make 

sure that you have the K12 schools layer selected in your layer list 

i. Select By Location 

ii. Again, select features from the K12 schools layer, and use the school districts 

layer as your selector 

iii. Make sure that Selected features only is checked 
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1. This time, change the Modify current selection by drop menu says 

adding to current selection 

2. Run 

3. How many features are now selected in the K-12 layer? _______ 

 

 

4. Extracting by Location 

Sometimes it is helpful and necessary to trim your data to a limited scope, especially if you dataset is 

very large.  Extracting by Location and Selecting by Location in order to extract are two methods for 

trimming your data. 

a. Remove all selections 

b. Pan to the Seattle School District 

c. We’d like to select all school districts that touch the waters of Lake Washington 

i. Click “Shoreline” 

ii. Hold the CTRL button, and then click the following districts 

1. Northshore 

2. Lake Washington 

3. Bellevue 

4. Renton 

5. Seattle 

6. Shoreline 

iii. In the Toolbox select Extract by Location 

1. In the Extracted(location) dialogue, it currently says [Create temporary 

layer] 

a. Click the […] radio button 

b. Select Save to File 

c. Navigate to the file folder containing your data 

d. Click on the drop menu that currently says “GPKG Files 

(*.gpkg)” 

e. Select “SHP (*.shp)” 

f. Name the file “LK_WA_Schls.shp” 

g. Save the file 

h. Select Run in Backgroud 

2. QGIS adds a layer called “Extracted(location)” to your layers list.  

Modifications you make to this layer will edit the LK_WA_Schls.shp file 

a. Right-click the “Extracted(location)” layer 

b. At the bottom of the drop menu, select “Rename” 

i. Rename the Layer “LK_WA_Schls” 
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5. “Extracting” by Location (Alternative) 

a. Deactivate the K12 layer 

b. Activate the Montessori Schools layer 

c. Repeat steps from Part 3 to select Montessori Schools by location 

i. If your polygons from the School Districts layer are no longer selected, make 

sure to repeat the selection steps rom “Section 4cii” 

ii. Select Features From “Montessori_Schools_Washington_State” 

iii. Select Are Within 

iv. Select School Districts 

v. Select Selected Features Only 

vi. Select Creating new selection 

vii. Select Run 

viii. Close the window 

ix. Right-click the Montessori Schools layer, and select “Open Attribute table” 

1. How many schools were selected? _________ 

x. Close the attribute talbe window 

xi. Right-click the Montessori Schools layer, and select Save Layers 

1. Select ESRI Shapefile as the format 

2. Click the […] Button 

3. Navigate to your project folder 

4. Name the file “LK_WA_Mont.shp” 

xii. In the Encoding section, select Save only selected features 

xiii. Make sure that Add saved file to map is selected 

xiv. Save the file 

xv. The new file will now to be added to the layers list  

 

6. Combining like vector files (point to point) 

In order to run spatial analyses, it is often necessary to have all relevant data housed in the same 

shapefile.  Spatial quantitative analysis will be addressed in future tutorials.  For now, we will practice 

the steps for combining similar datasets. 

a. Open the attribute tables for the LK_WA_Schls and LK_WA_Mont shapefiles 

i. Note similarities and differences between how data is classified and listed in 

each dataset 

b. Clear all selections 

c. Deactivate the original Montessori schools layer 

d. In the toolbox select Vector General → Merge Vector Layers 

i. Select the […] button in the Input Layers option 

ii. Fill the check boxes for LK_WA_Mont and LK_WA_Schls layer 

iii. Remove all other check boxes if any others are selected 

iv. Click OK 

v. The Input Layers listing should say “2 elements selected” 
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vi. For Destination CRS, select “Project CRS” 

vii. Click the […] button in the Merged section 

viii. Navigate to your project folder and name the file “LK_WA_Comb.shp” 

ix. Click the checkbox for Open output file after running algorithm 

x. Select Run in Backround 

We’ve encountered an Error!  Even though on the surface, the data structure seems to be the same, 

QGIS tells us that the “FID field layer in LK_WA_Schls has a different data type than in other layers 

(Integer instead of Integer65)”.  Forutnately, these data types are similar, and there are ways to edit 

data types using the “Refactor Fields” function. 

e. Make sure that the LK_WA_Schls layer is selected 

f. In the Toolbox, select Vector Table → Refactor Field 

i. In the drop menu in the FID row, select the Integer button in the Type field and 

change it to Integer64 

ii. Select Run in Background 

iii. A new layer called “Refactored” will be added to your layers list 

iv. Repeat the steps from “Section 6d” to merge files, but instead of using 

“LK_WA_Schls”, use “Refactored” 

v. Run the algorithm – a new layer called “Merged” will be created 

g. Open the attribute table for the new “Merged” layer 

It looks like we’ve gained a lot of columns!  Observe the outcome.  A few of the fields successfully 

merged, such as “County” and “Phone”.  But many others have not.  Open the attribute tables for 

LK_WA_Mont and LK_WA_Schls.  The Zip Code columns are named differently.  What are some other 

columns that are named differently?  QGIS is adept in identifying which columns are similar based on 

having fields with identical names as well as data types.  When you move on to your own projects, be 

sure to observe these differences in datasets.  This final section  

 

SELECTING with ATTRIBUTES and FILTERS 

You can also select features using data, known as “Filtering”,  “Select by Attribute”, or “Select Using 

Expression”. This is another way of trimming your dataset to limit which samples you can analyze in your 

dataset, as well as limiting symbology. 

7. Filters 

a. Activate the original K12_Schools layers, and deactivate all other layers 

b. Right-click the K12 Layer, and select Zoom to Layer 

c. Right-click the K12 Layer, and select Filter 

i. This will open a window called “Query Builder” 

ii. Double-click “Type” – note how the value is added to the Provide specific filter 

expression box 

iii. In the Values box, click All 

iv. Double-click “High School” 
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v. Click the Test button 

1. A pop-up window should arise: How many points were selected? _____ 

vi. Click OK 

vii. Right-click the K12_Schools layer, and save the layer as a new shapefile called 

“HighSchools.shp” – make sure that you are adding the new layer to the map 

viii. Right-click the K12_Schools layer, and selec Filter 

ix. Click the Clear button, and then close the window 

x. Make sure that the HighSchools layer is above the K12_Schools Layer 

xi. You have now extracted a sampling of high schools 

1. Zoom to a clustering of high schools 

2. Activate and deactivate the high school layers to see how they overlap 

with the old dataset 

 

ANALYZING DISSIMILAR VECTOR FILES 

Sometimes you would like to transfer data between files of different types, such as points and polygons.  

This can be useful to gathering information about locational commonalities of points, as well as 

tabulations of data within a polygonal boundary. 

8. Tabulating Data Using Polygons 

a. Activate the Zipcodes layer and the LK_Wa_Schls layer 

b. Select Vector → Analysis Tools → Count Points in Polygon 

c. Select the “Zipcodes” layer in Polygons 

d. Select the “LK_WA_Schls” layer for Points 

e. In the Weight Field select “Enroll2014” 

f. Rename the Count Field Name “ENR_2014” 

g. Make sure that the checkbox for Open output file after running algortithm is slected 

h. Select Run in Backround 

i. A new polygon field named “Count” will appear in your layers list 

j. Open the attribute table for the “Count” Layer 

i. Sort the “ENR_2014” field descending 

1. Which zipcode has the highest enrollment rate? ___________ 

2. How many zipcodes have any students at all? ________ 

3. There are many zipcodes with a count of “0”.  Why is this the case? 

___________________________________________________ 

 

9. Assigning Polygon Attributes to Points Using Location 

a. Select Vector → Data Management Tools → Join Attributes by Location  

b. Input Layer: Since we are trying to apply information from the Zipcode layer to the 

LK_WA_Schls layers, make sure that the LK_WA_Schls layer is selected here 

c. Join Layer: Select the Zipcodes layer 

d. Geometric Predicate: select Instersect 

e. Join Type: Create Separate Feature for Each Located Feature 
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Repeat the process: “I want my INPUT to adopt the attributs of my Join”. “I want my points to adopt the 

attributes of my polygons” 

f. Create a new file using the […] button, and name it “Schl_Zip” 

g. Open the attribute table for the new joined layer 

h. Scroll so that the “Zip” and “Zipcode_2” are visible, and observe that they match 


